sábado, 19 de noviembre de 2011

[Solución] Problemas con el wifi Broadcom BCM4311

Acabo de instalar Linux Mint 12  (Ubuntu 11.10) en un portátil con el wifi de Broadcom BCM4311, cual ha sido mi sorpresa cuando después de instalar el controlador desde controladores adicionales no me funcionaba. Para ver si me lo detectaba el ordenador he ejecutado:

sudo lspci -v 
Y la salida ha sido:
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 01)
Subsystem: Dell Wireless 1490 Dual Band WLAN Mini-Card
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f9ffc000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 2
Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Express Legacy Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Virtual Channel
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb
 La solución ha sido desinstalar el controlador e instalar un paquete que descarga e instala un controlador que funciona correctamente:
sudo apt-get purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer 
Y reinicia el equipo para que cargue los drivers al arrancar.

37 comentarios:

Muchas gracias por la información. Muy útil.

Gracias compadre....funciono super bien.

saludos

Ufff por fin.... esto sí me ha funcionado, gracias!!!

Excelente, muchisimas Gracias, ya tenia rato buscando como arreglarlo y no funcionaba, habia algunas "soluciones" que aparte de no funcionar me dejaban sin red alambrica. Como algo tan sencillo a veces se nos dificulta. Nuevamente Muchas Gracias.

No me funciono, podría ayudarme con otra opción. GRacias

Me funciono perfecto. Muchas gracias.

ERES UN MONSTRUO!!!!!!! GRACIAS.

Se purga bien si al final me da un mensaje:
Warning: No support for locale: es_MX.utf8
 

Yo tengo un BCM4318, probé lo que aquí se sugiere, pero sigue muerto el wifi...

 

  La solución ha sido desinstalar el controlador e instalar un paquete
que descarga e instala un controlador que funciona correctamente:

sudo apt-get purge bcmwl-kernel-source

sudo apt-get install firmware-b43-installer 

Y reinicia el equipo para que cargue los drivers al arrancar.

me trabajo a mi gracias .. 

Chingadera siempre que estreno version ubuntu me han de salir con una mamada, a lo mejor no es mi culpa ni la de los desarrolladores pero la neta si descepciona no tener al 100 mi vaio-vgn-cs220j que supongo aun no es nada vieja como pa tener achaques

Ya presentia que al menos no debia ser gran cosa mi problemita con el inalambrico, lo que paso es que al desmarcar "Activar inalambrico" se desactivaron mas opciones en este menu de opciones del manejador de inalambrico y al intentar reactivarlo con un click ya no me hacia caso y bueno como no supe reactivarlo via Terminal pues me fui por la facil, quitar desde el centro de software ubuntu al manejador de red gnome y poner yl famoso wicd, pero igual fue mi sorpresa que ahora si visualizaba el nombre asignado a mi ruteador pero igual al intentar conectarme me marcaba "Bad password" y eso que la contraseña estaba bien y el tipo de protecion tambien escogi la que es, en fin una cosa me llevo a otra y hasta pensar que debi hacer caso a eso de configurar el inalambrico antes de acabar una nueva reinstalacion del U-12.04 pero reintente de nuevo quitando el Wicd y reinstalando el Gnome netwoork manager y al menos ami eso me funcionó, y heme ahora comunicandome de forma inalambrica.. Maldito vicio inalambrico ----ggg.

Retiro lo dicho antes, después de reiniciar funciona perfecto!

DURE HORAS PARA RESOLVER MI PROBLEMA Y POR FIN ME ENCONTRE EL POST GRACIAS

Muchas gracias, información sumamente útil, problema resuelto. 

Excelente amigo, muchas gracias, soy nuevo en Ubuntu 12.04 y después de instalarlo ya no me funcionaba el WiFi, pero di con tu sugerencia y me funcionó, no se que significan los comandos que alistastes pero funcionaron bien, (en el terminal me salió un mensaje que instalara manualmente, después de ingresar el segundo comando de instalación, así que fuí a controladores adicionales y pudo descargar e instalar el controlador para que funcione WiFi).
Muchas gracias otra vez.

MUCHAS GRACIAS POR LA INFO ME AYUDO BASTANTE YA LOGRE LA CONEXION WIFI EN LA 12.04 LTS, GRACIAS.
ALGUIEN ME PUEDE AYUDAR, AHORA EL PROBLEMA QUE TENGO ES QUE NO ME APARECE EL ICONO DE BATERIA Y NO SE APAGA MI PC, ES UNA DELL 1420.

hago lo que dice acá, pero cuando pongo  sudo apt-get install b43-fwcutter, me sale lo siguiente:


Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  gir1.2-gstreamer-0.10 libgnomecanvas2-0 libbuzztard0 libfluidsynth1 libbml0
  libgstreamer0.10-dev buzztard-data libpcrecpp0 libhal1 libglib2.0-dev
  zlib1g-dev libglib2.0-doc libxml2-dev libxml2-doc libpcre3-dev
  libgstbuzztard0 libcrystalhd3 libgnomecanvas2-common
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes NUEVOS:
  b43-fwcutter
0 actualizados, 1 se instalarán, 0 para eliminar y 361 no actualizados.
Se necesita descargar 0 B/19,3 kB de archivos.
Se utilizarán 84,0 kB de espacio de disco adicional después de esta operación.
Cambio de medio: Por favor, inserte el disco etiquetado como
 «Xubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)»
en la unidad «/media/cdrom/» y pulse Intro


Pense que debía colocar el CD con el cual instaé el sistema pero al pulsar intro me vuelve a pedir que inserte el disco. Si pueden audarme estaría genial, llevo días intentando configurar el wifi.

A mí me sale esto:

 08:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
    Subsystem: Broadcom Corporation Device 051a
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at c5300000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Vendor Specific Information: Len=78
    Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-b5-ff-ff-bb-7c-4f
    Capabilities: [16c] Power Budgeting
    Kernel driver in use: wl
    Kernel modules: wl, bcma, brcmsmac


Qué tendría que hacer después en la terminal? Gracias por tu ayuda!

¡¡Gracias!! y muchas funcionò a la primera en Ubuntu 12.04 64bits.

Agradecido. Me soluciono el problema de wireless, muy bueno.

Muchas gracias amigo me funciono super bien para el ubunto 12.04

Muchas gracias, me soluciono la vida.

 Gracias amigo. No encontraba la solución a este problema. Estaba todo correcto pero el menu "activar inalambrico" no respondia al click. Cambie a Wicd y BINGO ya funciona. La pena es que no tengo icono indicador de red pero...menos es nada.
Gracias

mil gracias ya me estaba desesperando
 

Hola amigo, acabo de realizar esos comandos, reinicié y sigue sin funcionar el wifi... (ni siquiera funciona el interruptor) Tengo una Lenovo 3000 n200 con tarjeta igual a las especificaciones del post

Muchas gracias amigo, me na funcionado a la perfeccion ya me detecto la conecxión wifi en el ubuntu 12.04

llevo toda la tarde para configurarlo sin resultado,con tu tutorial,se ha solucionado el problema correctamente,mucha gracias

Los felicito de verdad muchas gracias me ha funcionado directo

Los felicito de verdad muchas gracias me ha funcionado directo

no se ha podido localizar el paquete firmware-b43-installer

Hola, he realizado los pasos que indicas pero no hay cambios, solo que lo hice con el driver de mi tarjeta, el problema es que la wifi no se activa, lo que sale es esto

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes

mi tarjeta es una RTL8101E/RTL8102E el compu no tiene activador fisico del wifi, solo el f11, el cuel esta encendido, pero en las conecciones de red la opcion Activar inalambrico esta bloqueada, tienes alguna sugerencia.


gracias

Fácil y eficaz. Perfecto para mi Acer 3690 con Ubuntu 12.04 y Broadcom BCM4311. Muchas gracias por tu colaboración.
Javi

GRACIAS!!!!! COJONUDO ESTO SI ME FUNCIONO!!!!!!!

Man gracias!!! por fin funciona el boton del wifi, funcionó a la primera.

Publicar un comentario en la entrada